Apache Solr远程代码执行漏洞(CVE-2019-12409)安全威胁通告

发布人: 发布时间:2019-12-11


综述

当地时间1118日,Apache Solr官方发布一则官方通告称部分Linux版本的Solr存在一个远程代码执行漏洞(CVE-2019-12409)。该漏洞源于默认配置文件solr.in.sh中的ENABLE_REMOTE_JMX_OPTS配置选项存在安全风险。

漏洞概述

如果使用受影响版本中的默认solr.in.sh文件,那么将启用JMX监视并将其暴露在RMI_PORT上(默认值= 18983),并且无需进行任何身份验证。 如果防火墙中的入站流量打开了此端口,则具有Solr节点网络访问权限的任何人都将能够访问JMX,并且可以上传恶意代码在Solr服务器上执行。

该漏洞不影响Windows系统的用户,仅影响部分版本的Linux用户。

参考链接:

https://lucene.apache.org/solr/news.html

影响产品版本

  • Apache Solr 8.2.0  for Linux

  • Apache Solr 8.1.1 for Linux

不受影响产品版本

Apache Solr目前尚未发布新版本修复该漏洞,但提供了缓解措施,请参照本文解决方案部分。

解决方案

Apache Solr官方尚未发布新版本修复该漏洞,请用户保持关注。

https://lucene.apache.org/solr/

Apache Solr官方提供了以下缓解措施:

  1. 用户可以将solr.in.sh 文件中的ENABLE_REMOTE_JMX_POTS 设置为 “False”,然后重启Solr

  2. 同时,用户应确认在Solr的管理员界面中的“Java Properties”选项中不包含 “com.sun.management.jmxremote*”的相关属性信息。

用户并不需要升级或更新任何代码。

更多信息请参考官方通告:

https://lucene.apache.org/solr/news.html

上一篇:重要:chromium-browser安全更新

下一篇:Harbor多个漏洞安全威胁通告